Duplicate class com.google.common.util.concurrent.ListenableFuture found in modules guava-20.0.jar (com.google.guava:guava:20.0)の対応方法


はじめに

flutterでのアプリ開発でパッケージをいくつかインストールし利用します。

タイトルにあるように、ビルドした結果、下記のエラーが発生しました。

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:checkDebugDuplicateClasses'.
> 1 exception was raised by workers:
  java.lang.RuntimeException: Duplicate class com.google.common.util.concurrent.ListenableFuture found in modules guava-20.0.jar (com.google.guava:guava:20.0) and listenablefuture-1.0.jar (com.google.guava:listenablefuture:1.0)

  Go to the documentation to learn how to <a href="d.android.com/r/tools/classpath-sync-errors">Fix dependency resolution errors</a>.

上記エラーの対応方法の備忘録です。

 

対応策

以下フォルダにあるbuild.gradleファイルを修正します。

[android]-[app]
   - build.gradle

「implementation 'com.google.guava:listenablefuture:9999.0-empty-to-avoid-conflict-with-guava'」を追加します。

dependencies {
    implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
    implementation 'com.google.guava:listenablefuture:9999.0-empty-to-avoid-conflict-with-guava'
}

無事ビルドに成功しました。

 

さいごに

これに結構はまりました。

参考までに。